Grid Control 10.2.0.5 installation on RHEL 5.4 x64

 

Linux requirements

Base release of the product is normally not supported on RHEL 5.0 but latest release is. So the *complexity* to install it:

Oracle Enterprise Manager 10g Grid Control Certification Checker [ID 412431.1]

Installation requirement for 10.2.0.5 Grid Control in OEL/RHEL 5(Linux x86-64) bit OS [ID 889692.1]

rpm -qa --queryformat "%{N}-%{VERSION}.%{RELEASE} (%{ARCH})n" | grep <package_name>

Here is the list for x86_64:

libXp-1.0.0.8.1.el5 (i386)
libXp-1.0.0.8.1.el5 (x86_64)
kernel-headers-2.6.18.128.el5 (x86_64)
gcc-c++-4.1.2.44.el5 (x86_64)
gcc-4.1.2.44.el5 (x86_64)
libstdc++-4.1.2.44.el5 (x86_64)
libstdc++-4.1.2.44.el5 (i386)
libstdc++-devel-4.1.2.44.el5 (x86_64)
make-3.81.3.el5 (x86_64)
libgomp-4.3.2.7.el5 (x86_64)
glibc-headers-2.5.34 (x86_64)
glibc-2.5.34 (x86_64)
glibc-devel-2.5.34 (i386)
glibc-2.5.34 (i686)
glibc-devel-2.5.34 (x86_64)
binutils-2.17.50.0.6.9.el5 (x86_64)
compat-db-4.2.52-5.1 (x86_64)
compat-db-4.2.52-5.1 (i386))
openmotif-2.1.30-11 (x86_64)
gdbm-1.8.0.26.2.1 (x86_64)
gdbm-1.8.0.26.2.1 (i386)

Do not forget to create the needed link (see reference note):

ln -s /usr/lib/libgdbm.so.2.0.0 /usr/lib/libdb.so.2

Oracle installation

How To Drop, Create And Recreate DB Control In A 10g Database [ID 278100.1]

Pleae note that the short release (in case you want to re-install so always use the definitive one):

--Step 1: Drop AQ related objects in the SYSMAN schemaLogon SQLPLUS as user SYSMAN
EXEC DBMS_AQADM.DROP_QUEUE_TABLE(queue_table=>'MGMT_NOTIFY_QTABLE',force =>TRUE);
--Step 2: Drop the DB Control Repository ObjectsLogon SQLPLUS as user SYS or SYSTEM,
--and drop the sysman account and management objects:
EXEC sysman.emd_maintenance.remove_em_dbms_jobs;
EXEC sysman.setEMUserContext('',5);
REVOKE dba FROM sysman;
DECLARE
CURSOR c1 IS
SELECT owner, synonym_name name
FROM dba_synonyms
WHERE table_owner = 'SYSMAN';
BEGIN
FOR r1 IN c1 LOOP
IF r1.owner = 'PUBLIC' THEN
EXECUTE IMMEDIATE 'DROP PUBLIC SYNONYM '||r1.name;
ELSE
EXECUTE IMMEDIATE 'DROP SYNONYM '||r1.owner||'.'||r1.name;
END IF;
END LOOP;
END;
/
DROP USER mgmt_view CASCADE;
DROP ROLE mgmt_user;
DROP USER sysman CASCADE;

How to Install Grid Control 10.2.0.5.0 on OEL/RHEL5/SLES10 Using the Existing Database (11g) Option [ID 784963.1]

As explained in the documentation prepare the em_using_existing_db.rsp, oms_patchset.rsp and agent_patchset.rsp response file.

/tmp/oracle/Disk1/runInstaller -noconfig -ignoreSysPrereqs -silent -responseFile /tmp/oracle/Disk1/response/em_using_existing_db.rsp use_prereq_checker=false b_skipDBValidation=true -force
/tmp/oracle/10205/3731593/Disk1/runInstaller -noconfig -silent -responseFile /tmp/oracle/10205/3731593/Disk1/response/oms_patchset.rsp
/tmp/oracle/10205/3731593/Disk1/runInstaller -noconfig -silent -responseFile /tmp/oracle/10205/3731593/Disk1/response/agent_patchset.rsp
export PERL5LIB=/ora_gc/oms10g/perl/lib/5.6.1
/ora_gc/oms10g/perl/bin/perl /ora_gc/oms10g/sysman/install/ConfigureGC.pl /ora_gc
tail -f /ora_gc/oms10g/cfgtoollogs/oui/configActions<date>.log

Look also at /ora_gc/oms10g/cfgtoollogs/oui/configActions.err

Errors and corrections

OCMRepeater

OCMRepeater is not Available after Upgrading Grid Control to 10.2.0.5 [ID 812060.1]

[oragc@server1 ~]$ echo $ORACLE_HOME
/ora_gc/oms10g
[oragc@server1 ~]$ $ORACLE_HOME/oc4j_OCMRepeaterDeploy.sh $ORACLE_HOME

Nmccollector

Problem: Core Dumps: 10.2 Agent core dumping every 5 minutes and/or emagent.trc shows WARN collector: Error exit. Error message: Instance Health Check initialization failed [ID 363170.1]

Grid Control session timeout

Fed up with the 15 minutes session idle time ?:

How to Change the Default Session Timeout on EM GRID Control and DB Control Connections [ID 234875.1]

Add in $ORACLE_HOME/sysman/config/emoms.properties (240 minutes = 4 hours):

oracle.sysman.eml.maxInactiveTime=240

Link error on HPUX 11.11

Error message is:

Error in invoking target 'agent nmo nmb nmhs emsubagent' of makefile '/opt/STMtools/STMoracleagent/agent10g/sysman/lib/ins_emagent.mk'.

Reference Metalink note is 831111.1.

There is patch 8500835 to solve the issue. Problem is that you can apply it only on HPUX and that it requires to be applied onto a installation folder (i.e. Disk1). If your central repository is on Linux you cannot apply it on your agent_download folder. Looking at the patch.sh script it is in fact a simple copy of one unique file filegroup40.jar into $OMS_HOME/sysman/agent_download/10.2.0.5.0/hpunix/agent/stage/Components/oracle.sysman.agent/10.2.0.5.0/1/DataFiles so quite easy to achieve. Do the copy and restart the installation.

4 thoughts on “Grid Control 10.2.0.5 installation on RHEL 5.4 x64

  1. Hi Yannick,

    I’ve trying yo install the 10.2.0.3 Base release on RHEL 5.4. Imposible…

    After installing oracle-validated and more stuff like that…
    yum install zlib-devel
    rpm -ivh libpng10-devel-1.0.13-8.i386.rpm libpng10-1.0.13-8.i386.rpm
    yum install gdk-pixbuf glib gtk+
    rpm -ivh imlib-1.9.15-11.el5.x86_64.rpm
    rpm -ivh imlib-devel-1.9.15-11.el5.x86_64.rpm

    It was imposible to resolve this 3 packages: gnome-libs, xscreensaver and openmotif21

    [root@db05 GRID_CONTROL]# rpmbuild –rebuild xscreensaver-4.18-5.rhel4.2.src.rpm
    error: Failed build dependencies:
    XFree86-devel is needed by xscreensaver-4.18-5.rhel4.2.x86_64
    [root@db05 GRID_CONTROL]# rpmbuild –rebuild gnome-libs-1.4.1.2.90-44.1.src.rpm
    error: Failed build dependencies:
    ORBit-devel is needed by gnome-libs-1.4.1.2.90-44.1.x86_64
    —————————

    I’ve already request the 10.2.0.5 BASE RELEASE if exist, because it’s imposible to install Grid Control 10.2.0.3 on RHEL 5.4.
    Only downgrading to RHEL 4 I think so.

    What do you think about it?

    Regards,
    Daniel

    • Hi Daniel,

      Why rpmbuild and not rpm ? Using something like rpm -Uvh you should be proposed to install dependencies if your server has a well configured package repository…

      Beyond this, why working to install 10.2.0.3 while 10.2.0.5 is available ? Do you know that after Grid Control 10gR2 there was Grid Control 11gR1 and now Cloud Control 12c. RedHat 5 is soon to be de-supported as well (not to mention RedHat 4)…

      I strongly suggest you move to Cloud Control 12c on RedHat 6, that is clearly more user friendly and repository java processes are really more stable (Weblogic also helps of course). To finally convinced you if I have to list one functionality that rocks in Cloud Control 12c you really need to give a try, I straight choose ASH Analytics !

      Thanks, Yannick.

  2. Hi Yannick,

    I choose these releases (OS 5.4 & EMGC 10.2.0.3) because they are specified for the OCM 11g exam.
    I requested the 10.2.0.3 and 10.2.0.5 old versions to practice this installation and the related tasks but
    the 10.2.0.5 is only a PSU and not a base software installation.
    The 10.2.0.3 is the base software.

    RHEL 5.4 doesn’t have these packages: “gnome-libs, xscreensaver and openmotif21”
    RHEL 4.8 have it all and it was easy to install 10.2.0.3 and upgrade it to 10.2.0.5, then I started to install agents to monitor and everything works.

    I’m looking for somebody that can give me an idea about installing 10.2.0.3 on RHEL 5.4 because it’s specified as “Exam environment” in the Oracle website. Then I feel a bit uncomfortable about this.

    Thanks for the -U upgrade option, sometimes I’ve used but in this subject I’m trying to install old packages “.arch” or rebuilding the RPMs from old releases for my required environment.

    http://education.oracle.com/pls/web_prod-plq-dad/db_pages.getpage?page_id=5001&get_params=p_exam_id:11GOCM

    Well, I have a very good news, I’ve just check that It was changed to GRID 11.1.0.1.
    So, It’s the solution to my problems… WOW !!

    Thanks in advance Daniel

    • Hi Dani,

      I’m also preparing OCM exam 🙂 …

      And I share the (previous) need of Grid 10gR2 for this exam but as you rightly mentioned, starting from 13th May 2013 this is now 11gR1. I’m wondering why they moved from 64 bits to 32 bits as the industry standard is clearly 64 bits…

      I also see that they are going to remove Streams which is even a more good news for me as (unfortunately) I know a bit the product (I followed the Streams training) !

      I will prepare a 11gR1 Grid on OEL 5.4 32 bits to also practice a bit this old product…

      Thanks, Yannick.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes:

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>